すべてのコレクション
チャットボットのリリース
Instagram版
Instagramボットの接続やリリースが上手くいかない場合のトラブルシューティング
Instagramボットの接続やリリースが上手くいかない場合のトラブルシューティング

インスタグラムのアカウントとチャットボットを接続する際のエラーのメッセージ一覧。Instagramアカウントがリリース画面に表示されなかったり、接続できてもメッセージがちゃんと送受信できなかったり、Instagramアカウントがビジネスアカウントでない場合の解決する対処法。

CrafterSupport avatar
対応者:CrafterSupport
一週間前以上前にアップデートされました

Instagramアカウントの接続関連のトラブルシューティング一覧です。

※エラーメッセージが分かる場合、ブログ内で検索いただくとスムーズです。

  1. リリース時(接続ボタンをクリックするタイミング)

    1. ユーザー権限エラーのアラートが表示

  2. リリース後(ダッシュボードにアクセスする際)

    1. ページトークンエラーのアラートが表示

    2. アカウントエラーのアラートが表示

    3. DMが無効エラーのアラートが表示

    4. 予期しないエラーのアラートが表示

    5. APIエラーのアラートが表示

    1. 現象② ユーザートークンエラーのアラートが表示

    2. 現象③ ユーザー権限エラーのアラートが表示

    3. 現象④ ページトークンエラーのアラートが表示

  3. 接続解除(ページとの接続を解除する際)


リリース前

Instagramアカウント一覧に接続したいInstagramアカウントが表示されない

Instagramアカウント一覧に、自分が接続したいInstagramアカウントが表示されない場合の対処法です。

以下の条件だと発生する可能性あり

  • Instagramアカウントを一度も連携したことがない

  • InstagramやFacebookアカウントの権限がない

  • 以前連携した時に選んだアカウントとは別の新規Instagramアカウントを作成した

解決方法

Instagramアカウントが表示されるが接続ボタンが灰色で押せない

接続ボタンは表示されるが灰色でボタンが押せない場合は、接続するために自身のInstagramアカウントがリンクしているFacebookページの権限が足りないことがあります。

考えられる原因と解決方法


リリース時(接続ボタンをクリックするタイミング)

ユーザー権限エラーが表示

現象

  • ページまたはInstagramアカウント の「連携」ボタンを押すと

    ユーザー権限エラー 』のアラートが表示される

エラーメッセージ

ユーザーには、このページまたInstagramアカウントでこの操作を行う
ための十分な権限がありません。 ページ管理者に依頼して、必要な権限
を追加してもらってください。その上で、「アカウント同期」を実施
し、接続(更新/解除)ボタンをクリックしてください。

影響

  • 接続できない

考えられる原因と解決方法

  • Facebookページに対して必要な権限を持ってない

  • CraftChatアプリに、Facebookページの必要な権限を付与していない

    • リリースページにて「アカウント同期」をもう一度実施して、 連携したいページとInstagramアカウントのチェックを入れ、 リクエストするすべての権限をOnにする。

      アカウントを同期中、Facebookページ・アカウントにチェックが入っていることを確認してください


リリース後

ページトークンエラー

発生場所

  • 管理画面ページ左下、どのページでも。

    エラーが解除されない限りずっと表示されます。

現象

  • ページトークンエラー 』のアラートが表示される

エラーメッセージ

Metaシステム側でページアクセストークンが無効になり、ボットとの接続が切れています。ユーザーとの会話が出来なくなります。リリースページにて、「アカウントを同期」のボタンをクリックの上、「接続更
新」してください。

影響

  • アクセストークンが失効になると、 ボットとの会話が出来なくなります。

考えられる原因と解決方法

原因:

  • Facebookアカウントトークンが約60〜90日間の有効期限が過ぎた

  • Facebookアカウントのパスワードを変更

  • Facebookシステムの判断によるセキュリティの原因

  • ユーザーがFacebookアカウントから元々承認した権限を削除した

  • ユーザーがFacebookアカウントからCraftChatアプリを削除した

解決方法:

  • リリースページにて「アカウント同期」した後、「接続更新」ボタンを押す

原因

  • Facebookアカウント自体が削除された

解決方法:

  • 新規アカウントでログインし、 リリースページにて「アカウント同期」した後、「接続更新」ボタンを押す


アカウントエラー

発生場所

  • 管理画面ページ左下、どのページでも。

    エラーが解除されない限りずっと表示されます。

現象

  • アカウントエラー 』のアラートが表示される

エラーメッセージ

利用しているInstagramアカウントはビジネスアカウントではありませ
ん。ビジネスアカウントに変更ください。

影響

  • ボットとの会話ができない

考えられる原因と解決方法

原因:

  • InstagramアカウントとFacebookページとのリンクが切れている

  • Instagramアカウントがビジネスアカウントまたはクリエイターアカウントでない

解決方法:

  • 「アカウントを同期」ボタンをクリックし、FacebookページやInstagramアカウントが選択されていることを確認する

  • Instagramアカウントをビジネスアカウントに切り替える

Instagramのアカウントはビジネスアカウントを設定する必要があります。どのアカウントでも無料で「ビジネスアカウント」に変更することが出来ます。

以下のステップにて設定ください。

  1. Instagramにログインし、[設定]で[アカウント] を選択し、[プロアカウントに切り替える]をタップします。

  2. アカウントタイプ[ビジネス]を選択、さらにカテゴリやその他を選択し進めます。

  3. これでInstagramビジネスアカウントを取得できました。

自分のInstagramアカウントがビジネスアカウントか分からない場合は、以下の方法で確認できます。

  • Instagramにログイン

  • [設定]で[アカウント]をクリック

  • 左下が下の写真のように「プロアカウントに切り替える」の場合、ビジネスアカウントではありません。本来ならビジネスアカウントの場合、「個人用アカウントに切り替える」と表示されます。

DMが無効エラー

発生場所

  • 管理画面ページ左下、どのページでも。

    エラーが解除されない限りずっと表示されます。

現象

  • DMが無効エラー 』のアラートが表示される

エラーメッセージ

アカウントの所有者は、Instagramのダイレクトメッセージへのアクセ
スを無効にしています。Instagramアプリにて設定を変更してください。

影響

  • ボットとの会話ができない

考えられる原因と解決方法

原因:

  • Instagramアカウントの所有者がDMの設定をしていない/間違えた

解決方法:

  • Instagramビジネスアカウントでメッセージアクセスを許可している

    Instagramビジネスアカウントのプロフィールから、右上の「三」→「設定」→「プライバシー」→「メッセージ」→「メッセージへのアクセスを許可」のトグルがオン(青色)になっていることを確認。

予期しないエラー

発生場所

  • 管理画面ページ左下、どのページでも。

    エラーが解除されない限りずっと表示されます

現象

  • 予期しないエラー 』のアラートが表示される

エラーメッセージ

Meta側で予期しないエラーが発生しました。しばらく待ってからもう
一度お試してください。

影響

  • 不明

    会話できない場合がありますが、 何も影響がない時もある

考えられる原因と解決方法

  • Meta側のシステムエラーなので、弊社側では原因はわかりません

    • 念の為ボットとの会話を一度テストしてください。

APIエラー

発生場所

  • 管理画面ページ左下、どのページでも。

    エラーが解除されない限りずっと表示されます

現象

  • APIエラー 』のアラートが表示される

エラーメッセージ

Meta側のプラットフォームAPIエラーが発生しました。しばらく待って
からもう一度お試してください。

影響

  • 会話できない可能性が大

考えられる原因と解決方法

  • Meta側のシステムエラーなので、弊社側では原因はわかりません

    • 念の為ボットとの会話を一度テストしてください。


接続更新時

  • ページトークンエラー』が表示される

  • ページ連携は切れました』というメールが来る

前提条件

  • 接続を行うユーザーが持っているFacebookアカウントがFacebookページ(Instagramアカウントとリンクしているページ)に対して十分な権限を持っている

例)Facebookアカウント田中花子は、 CraftChat管理画面にログインできるユーザー田中花子として登録している。

  • OK:Facebookアカウント田中花子は、接続したいFacebookページ「田中喫茶店」の管理者を持っている。

  • NG:Facebookアカウント田中花子がFacebookページ「田中喫茶店」の管理者でないと、接続できません。

発生場所

  • リリースページ

解決方法

  • 接続更新ボタンをクリック

    • ※もし問題がある場合は、下の現象①〜④をご覧ください。

現象① 「接続更新」ボタンをクリックできない

  • リリースページに遷移、もし「接続更新」ボタンが下図のようにクリック出来ない状態で、ボタンの右側にポップアップが表示する場合、「Facebookアカウントと連携」ボタンを押してください。

上記のアカウントを同期後、リリースページで「接続更新」ボタンをクリックし、接続更新してください。

現象② ユーザートークンエラーのアラートが表示される

  • 「接続更新」 ボタンを押したらページの左下に

    ユーザートークンエラー 』のアラートが表示される

エラーメッセージ

Facebookアカウントと接続できておらず、ユーザートークンが見つか
りません。ご自身のFacebookアカウントとCraftChatで連携するよ
う、「Facebookアカウントと連携」ボタンを押してください。

影響

  • 接続更新失敗

考えられる原因と解決方法

原因

  • 接続更新の手順を無視して、 Facebookアカウントと連携していない状態で 接続更新ボタンを押した

解決方法

  • リリース画面の「Facebookアカウントと連携」ボタンを押してください。

現象③ ユーザー権限エラーのアラートが表示される

  • 「接続更新」 ボタンを押したらページの左下に
    ユーザー権限エラー 』のアラートが表示される

エラーメッセージ

ユーザーには、このページまたInstagramアカウントでこの操作を行う
ための十分な権限がありません。 ページ管理者に依頼して、必要な権限
を追加してもらってください。その上で、「アカウント同期」を実施
し、接続(更新/解除)ボタンをクリックしてください。

影響

  • 接続更新失敗

考えられる原因と解決方法

  • 接続更新の手順を無視して、 Facebookページに対して権限が足りない状態(管理者でないか、チェックを入れていない)で 接続更新ボタンを押した

現象④ ページトークンエラー のアラートが表示

  • 「接続更新」 ボタンを押したらページの左下に

    ページトークンエラー 』のアラートが表示される

エラーメッセージ

Metaシステム側でページアクセストークンが無効になり、ボットとの
接続が切れています。ユーザーとの会話が出来なくなります。リリース
ページにて、「アカウントを同期」のボタンをクリックの上、「接続更
新」してください。

影響

  • 接続更新失敗

考えられる原因と解決方法

  • 接続更新の手順を無視して、 Facebookページに対して権限が足りない状態(シンプルに管理者でないか、チェックを入れていない)で 接続更新ボタンを押した


接続解除(ページとの接続を解除する際)

接続解除エラー(現象①〜②)

発生場所

  • リリースページ

現象① ユーザートークンエラーのアラートが表示される

  • 「接続解除」 ボタンを押したらページの左下に

    ユーザートークンエラー 』のアラートが表示される

エラーメッセージ

Facebookアカウントと接続できておらず、ユーザートークンが見つか
りません。ご自身のFacebookアカウントとCraftChatで連携するよ
う、「Facebookアカウントと連携」ボタンを押してください。

影響

  • 接続解除失敗

考えられる原因と解決方法

原因:

  • Facebookアカウントと連携していない状態で「接続解除」ボタンを押した

解決方法:

  • リリース画面の「Facebookアカウントと連携」ボタンを押してください。

現象② ユーザー権限エラーのアラートが表示される

  • 「接続解除」 ボタンを押したらページの左下に

    ユーザー権限エラー 』のアラートが表示される

エラーメッセージ

ユーザーには、このページまたInstagramアカウントでこの操作を行う
ための十分な権限がありません。 ページ管理者に依頼して、必要な権限
を追加してもらってください。その上で、「アカウント同期」を実施
し、接続(更新/解除)ボタンをクリックしてください。

影響

  • 接続解除失敗

考えられる原因と解決方法

  • 接続更新の手順を無視して、 Facebookページに対して権限が足りない状態(シンプルに管理者でないか、チェックを入れていない)で 「接続解除」ボタンを押した


その他

基本的にMeta側での設定誤りかMeta社の不具合となります。

複数アプリがありFacebookページの設定でハンドオーバープロトコルが設定されていない

  • Facebookページが複数アプリと紐付いている場合、こちらで解決できる可能性が高いです。

Instagramビジネスアカウントとリンク」したFacebookページの「ページ設定」>「メッセージの詳細設定」タブをクリック。

「リンク済アプリ」に「CraftChat」が入っていることを確認し、「ハンドオーバープロトコル」の設定を変更してください。

Messenger receiverの「設定」ボタンをクリックし、「プライマリ受信者」として「CraftChatApp-Test your bot-」を選択。

セカンダリ受信者は空のままで大丈夫です。

Instagram receiverの「設定」ボタンをクリックし、上のMessenger Receiverと同じく「プライマリ受信者」に「CraftChatApp-Test your bot-」を選択。

セカンダリ受信者も空のままで大丈夫です。

Instagram接続時に『ページ作成エラー』が表示される場合

  • 『新しいFacebookページを作成しますか?』の表示画面で『はい』をクリックした後に『 ページ作成エラー』が表示される場合は、Facebook側のエラーのため、時間をおいて再度お試しください。

チャット取得時に『リード一覧を取得する際にエラーが発生しました。』エラーが表示

  • ページ取得に時間がかかっている状態です。少しお待ちいただきアクセスをお試しください。

関連リンク

こちらの回答で解決しましたか?